Heizbett fährt nach Druck nach oben

Hier könnt Ihr Lob, Kritik, Verbesserungen oder Änderungen anregen und diskutieren.
Maggo-3
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 203
Registriert: Sa 17. Jan 2015, 11:47
Hat sich bedankt: 1 Mal
Danksagung erhalten: 25 Mal

Heizbett fährt nach Druck nach oben

Beitrag #1 von Maggo-3 » Di 24. Feb 2015, 22:14

Hallo Leute.

Mir ist jetzt mal aufgefallen, dass mein Drucker, wenn der Druck beendet ist erst einmal in die 'Output Object' Position fährt.
Dann fährt er allerdings direkt wieder nach oben, sodass das gedruckte Objekt knapp unter dem Extruder liegt.

Das kommt mir so vor, als ob da irgend ein Befehl vom Repetierhost sich mit dem Drucker überschneidet oder ähnliches.

Ist das bei euch auch so?

Wie kann ich das denn einstellen, dass er nach jedem Druck in die 'Output Object' Position geht?



Mir fällt da gerade sogar noch etwas zu ein.
Ich kann den Drucker auch manuell über das Bedienfeld oder Repetierhost immer nur um ein paar cm nach unten veschieben, weiter geht er das Bedienfeld nicht.
Wenn ich Platz benötige muss ich immer erst auf Home All und dann auf Output Object gehen.

Danke für eure Hilfe
RF1000 Bausatz - Repetier-Server Pro - E3DV6 Titan Total Conversion - MTPlus DDP - V1.41.11 dev Mod - Silikonsocken - Stepperkühlung - Radiallüfter

Benutzeravatar
R3D3
Developer
Developer
Beiträge: 473
Registriert: Mo 26. Jan 2015, 13:41
Wohnort: München
Hat sich bedankt: 28 Mal
Danksagung erhalten: 54 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #2 von R3D3 » Mi 25. Feb 2015, 08:09

Maggo-3 hat geschrieben:Hallo Leute.

Mir ist jetzt mal aufgefallen, dass mein Drucker, wenn der Druck beendet ist erst einmal in die 'Output Object' Position fährt.
Dann fährt er allerdings direkt wieder nach oben, sodass das gedruckte Objekt knapp unter dem Extruder liegt.
[...]
Ich kann den Drucker auch manuell über das Bedienfeld oder Repetierhost immer nur um ein paar cm nach unten veschieben, weiter geht er das Bedienfeld nicht.
Wenn ich Platz benötige muss ich immer erst auf Home All und dann auf Output Object gehen.
[...]


Beides ist bei mir nicht der Fall. Für eine weitere Analyse des Problems mit der geballten Kenntnis des Forums wäre es zumindest nützlich, die Firmwareversion und die des Repetierhost zu erfahren.
Gruß
R3D3
Schönen Gruß - R3D3 :victory:

RF1000 | 0.91.48dual | RH 1.6.2 | plus noch:
- Z-Endschalter "+", Not-Aus, Erhöhte X-Schleppkette
- Dual Extruder; angepasste Einhausung; Boardkühlung,
- Dauerdruckplatte, Extrudermotorlüfter

Maggo-3
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 203
Registriert: Sa 17. Jan 2015, 11:47
Hat sich bedankt: 1 Mal
Danksagung erhalten: 25 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #3 von Maggo-3 » Mi 25. Feb 2015, 10:31

Der Drucker hat die Firmware 0.91.33
Vom Repetier Host finde ich leider nur folgende Infos:
The software is based on Repetier-Host version 0.90 with Apache License, Version 2.0.

Was sollte denn normalerweise nach dem Druck passieren?
Fährt er normalerweise einfach in die output Object Position?
RF1000 Bausatz - Repetier-Server Pro - E3DV6 Titan Total Conversion - MTPlus DDP - V1.41.11 dev Mod - Silikonsocken - Stepperkühlung - Radiallüfter

Benutzeravatar
R3D3
Developer
Developer
Beiträge: 473
Registriert: Mo 26. Jan 2015, 13:41
Wohnort: München
Hat sich bedankt: 28 Mal
Danksagung erhalten: 54 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #4 von R3D3 » Mi 25. Feb 2015, 11:29

Maggo-3 hat geschrieben:Der Drucker hat die Firmware 0.91.33
[...]
Fährt er normalerweise einfach in die output Object Position?


Bei mir ja. Meine FW ist die 0.91.48, die gegenüber der .33 einiges verbessert. Zum Updaten siehe Anleitung.
Schönen Gruß - R3D3 :victory:

RF1000 | 0.91.48dual | RH 1.6.2 | plus noch:
- Z-Endschalter "+", Not-Aus, Erhöhte X-Schleppkette
- Dual Extruder; angepasste Einhausung; Boardkühlung,
- Dauerdruckplatte, Extrudermotorlüfter

Benutzeravatar
SirShadowless
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 200
Registriert: Mo 15. Sep 2014, 11:48
Wohnort: nähe Wien
Hat sich bedankt: 10 Mal
Danksagung erhalten: 7 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #5 von SirShadowless » Mi 25. Feb 2015, 12:21

Die Firmware hat nicht zwingend was mit den Bewegungen des Druckers zu tun...

Interessant ist der g-Code der verwendet wird, speziell der endcode.

Der Drucker befolgt ja auch nur die "Befehle" die er bekommt...

Poste mal den g-Code und dann schauen wir weiter.
lg Andy

PS: zeit ist zu kostbar um auf groß und kleinschreibung zu achten :D

Benutzeravatar
rf1k_mjh11
Developer
Developer
Beiträge: 1693
Registriert: Di 6. Jan 2015, 19:44
Wohnort: Autriche
Hat sich bedankt: 214 Mal
Danksagung erhalten: 430 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #6 von rf1k_mjh11 » Mi 25. Feb 2015, 13:25

Maggo-3,

Überprüfe auch dein "End-GCode". Auch da kann der Hund drin stecken.

AAHHH - ich sehe SirShadowless hat schon dasselbe geschrieben.

mjh11
Merke, am PC gibt es immer einen Weg!
Schafft es der Mensch, einmal etwas idiotensicher zu machen, kontert die Natur sofort mit einem besseren Idioten.

Maggo-3
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 203
Registriert: Sa 17. Jan 2015, 11:47
Hat sich bedankt: 1 Mal
Danksagung erhalten: 25 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #7 von Maggo-3 » Mi 25. Feb 2015, 14:59

Hier mal ein G-Codebeispiel.

Die Software werde ich dann heute Abend auch mal aktualisieren.
Vielleicht bringt das ja auch was :)


EDIT:
Irgendwie will er mir den Code nicht hochladen, daher mal ein Screenshot der letzten paar Zeilen, hoffe das hilft.
RF1000 Bausatz - Repetier-Server Pro - E3DV6 Titan Total Conversion - MTPlus DDP - V1.41.11 dev Mod - Silikonsocken - Stepperkühlung - Radiallüfter

Maggo-3
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 203
Registriert: Sa 17. Jan 2015, 11:47
Hat sich bedankt: 1 Mal
Danksagung erhalten: 25 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #8 von Maggo-3 » Mi 25. Feb 2015, 15:08

Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
RF1000 Bausatz - Repetier-Server Pro - E3DV6 Titan Total Conversion - MTPlus DDP - V1.41.11 dev Mod - Silikonsocken - Stepperkühlung - Radiallüfter

Benutzeravatar
rf1k_mjh11
Developer
Developer
Beiträge: 1693
Registriert: Di 6. Jan 2015, 19:44
Wohnort: Autriche
Hat sich bedankt: 214 Mal
Danksagung erhalten: 430 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #9 von rf1k_mjh11 » Do 26. Feb 2015, 15:31

Maggo-3,

Da musste ich ein bisschen recherchieren. Ich habe schon eine neuere Firmware, und da haben sich ein, zwei Befehle geändert.

Zuerst einmal den GCode analysieren:

G92 E0 --->setzt die Extruder Koordinate zurück, bzw. auf '0'
M104, M140 ---> Bett- und Extruderheizung ausschalten
G91 ---> vom Absolutkoordinatenmodus in den relativen umschalten
G1 E-5 F300 --->5mm Fialment zurückziehen (damits net sabbert)
M400 ---> warte bis alle Schritte abgearbeitet
M3079 ---> Hier wird das Teil ausgegeben (Bett 'runter, usw.). Theoretisch OK, ABER, bei deiner Firmware sollte die
Ausgabeposition durch dem 'M3104'-Befehl vorher konfiguriert werden. Wohin der Drucker geht, ohne dass diese Position bekannt ist, weiß ich nicht.. Steht bei dir im Start-GCOde irgendwo eine Zeile mit "
M3104"? Die "Ausgabeposition" sollte sinnvollerweise mit dem Bett ganz nach vorne gefahren, und an einer recht niedrigen Position sein. Wo dabei der Extruder stehen soll, ist nicht unbedingt wichtig. Was allerdings hilt, ist die Motore abzuschalten. dies geschieht mit:
M84 ---> Motore abschalten
M201, M202 ---> Beschleunigungswerte für Drucken und Fahrt auf den Standardwert (1000) zurücksetzen.
M104, M140 ---> Bett- und Extruderheizung wieder ausschalten (ist redundant!)
G90 ---> vom Relativkoordinatenmodus in den absoluten zurück umschalten
G1 X0 Y0 F4800 ---> hier könnte evtl. der Hund begraben liegen. Der Extruder fährt nach rechts (das ist eigentlich egal), und das Bett fährt wieder nach Hinten (eher nicht gut, da ungeschickt beim 'entladen'). Allerdings gibt es keinen Hinweis, wieso das Bett wieder nach oben fahren sollte. Es fehlt ein Fahrbefehl in Z-Richtung.

Gibt es keine Befehle nach dem letzten 'M84'-Befehl, kann ich mir nicht erklären, wieso das Bett zum Schluß wieder nach oben fährt. Allerdings geht mir auch der 'M3104'-Befehl ab. Ich habe versucht, in der Firmware einen Hinweis zu finden, wohin der Drucker fährt, falls keine Vorgabe mittels M3104 stattgefunden hat. Ich habe allerdings (noch) nichts gefunden.

mjh11
Merke, am PC gibt es immer einen Weg!
Schafft es der Mensch, einmal etwas idiotensicher zu machen, kontert die Natur sofort mit einem besseren Idioten.

RF1000
Developer
Developer
Beiträge: 340
Registriert: Fr 10. Okt 2014, 16:31
Hat sich bedankt: 40 Mal
Danksagung erhalten: 78 Mal

Re: Heizbett fährt nach Druck nach oben

Beitrag #10 von RF1000 » Fr 27. Feb 2015, 14:14

Hallo,


grundsätzlich hat mjh11 das schon super zusammen gefasst - da bleibt für mich nicht mehr viel übrig :-)
Zu M3104 kann ich aber sagen, dass die Firmware natürlich Defaultwerte hat die verwendet werden, falls kein M3104 gesendet wird.

Grundsätzlich bin ich aber natürlich auch der Ansicht, dass ein Firmware Update sinnvoll ist, wenn bisher die V 0.91.33 verwendet wird. Bitte gib' uns Bescheid ob dieses Verhalten danach immer noch auftritt.


mfG
RF1000


Zurück zu „RF1000 Forumstalk“