RF2000 Extruder Lüfter gehen nicht mehr

Hier geht es ausschliesslich um die Extruder und Kühlung des Filamnts des RF2000. Fragen und Probleme sowie Verbesserungen können hier diskutiert werden
HugoSchmid
Frischling
Frischling
Beiträge: 3
Registriert: Mo 21. Mai 2018, 15:34
Wohnort: Wien

Re: RF2000 Extruder Lüfter gehen nicht mehr

Beitrag #61 von HugoSchmid » So 27. Mai 2018, 18:40

Herzlichen Dank!
Jetzt gerade läuft ein Probedruck auf dem RF2000.
Werde es probieren, wenn der Druck fertig ist und ich wieder Zeit dazu finde.
LG,
Hugo

Benutzeravatar
AtlonXP
3D-Drucker Erfinder
3D-Drucker Erfinder
Beiträge: 3011
Registriert: So 15. Nov 2015, 20:55
Hat sich bedankt: 669 Mal
Danksagung erhalten: 518 Mal

Re: RF2000 Extruder Lüfter gehen nicht mehr

Beitrag #62 von AtlonXP » So 27. Mai 2018, 19:44

Hallo,
am RF1000 ist nur ein Bauteillüfter verbaut.

Diesen kann ich sehr genau regeln.
Die Regelung geht sogar auf 1% genau und kann sogar dank Nibbels noch feiner.

Für mich ist der Einstellbereich von 0 – 20 % interessant.
Damit mein Lüfter so genau funktioniert ist die niedrigste PWM Frequenz einzustellen.

Bei höherer Hz. lässt die Genauigkeit nach.
Also auf 0 = 15.25Hz ist bei mir die beste Einstellung.
Ich glaube, der Startpilot wäre bei mir nicht nötig.

LG AtlonXP

Benutzeravatar
Nibbels
Developer
Developer
Beiträge: 2269
Registriert: Mi 17. Aug 2016, 17:01
Hat sich bedankt: 832 Mal
Danksagung erhalten: 597 Mal

Re: RF2000 Extruder Lüfter gehen nicht mehr

Beitrag #63 von Nibbels » So 27. Mai 2018, 20:32

AtlonXP hat geschrieben:Für mich ist der Einstellbereich von 0 – 20 % interessant.
Damit mein Lüfter so genau funktioniert ist die niedrigste PWM Frequenz einzustellen.


Genau das ist der Punkt. Von 20% bis 100% kommen bei dir vermutlich auch zwischen 99% und 100% Luftstromstärke raus.

LG
RF2000
Firmware Mod 1.45.00.Mod - geht SD wieder 100%?

Bitte 1.42.17 bis 1.42.21 meiden!
SD-Druck mit der Community-FW <= 1.43.99 aktuell meiden.

Benutzeravatar
AtlonXP
3D-Drucker Erfinder
3D-Drucker Erfinder
Beiträge: 3011
Registriert: So 15. Nov 2015, 20:55
Hat sich bedankt: 669 Mal
Danksagung erhalten: 518 Mal

Re: RF2000 Extruder Lüfter gehen nicht mehr

Beitrag #64 von AtlonXP » So 27. Mai 2018, 20:51

Nibbels hat geschrieben:
Genau das ist der Punkt. Von 20% bis 100% kommen bei dir vermutlich auch zwischen 99% und 100% Luftstromstärke raus.


Nö nö, da geht schon noch einiges mehr!

Ich kann nur sagen bei mir funzt es einwandfrei.

LG AtlonXP

Benutzeravatar
Nibbels
Developer
Developer
Beiträge: 2269
Registriert: Mi 17. Aug 2016, 17:01
Hat sich bedankt: 832 Mal
Danksagung erhalten: 597 Mal

Re: RF2000 Extruder Lüfter gehen nicht mehr

Beitrag #65 von Nibbels » Mo 25. Jun 2018, 09:15

:boing:

Eine Lösung zu dem Problem mit den Lüftern macht Fortschritte.
Ich kann vorerst nur eine Aussage zu genau meiner Situation machen.

1% Einstellwert war zu schnell.
100% Luftstrom zu früh erreicht.
Also eine stark nichtlineare Übersetzung von Einstellzahl zu Resultat.

Wir konnten bisher die PWM frequenz des Partfan bei 15.3 Herz oder einem faktor 2/bzw 4 höher einstellen. Doch dann litten die möglichen Einstellstufen zunehmend. Das lag aber an dem hochoptimierten 8bit code.
Je höher die Frequenz, desto mehr Power hatte mein Lüfter in seiner Minimaleinstellung.
Doch wer Anlaufprobleme bei 1% hatte konnte das damit auf kosten der Steuerbarkeit durch mehr frequenz lösen.


Ich habe Am Wochenende die Änderungen von RF.1.39 zur 1.42 genau nachvollzogen.


RF1000 geht nun einen anderen Weg. Die Frequenz so niedrig machen, dass die Steuerbarkeit hoch wird und
Ein MinimumPWM auf 1% übersetzen
Ein MaximumPWM auf 99% hochziehen.

Also ziehen wir den sinnvollen Teil des Ansteuerbereichs auf 1%..99% Einstellwert auseinander.
Mein erster Test mit der Idee, auf die wir schon länger hatten kommen müssen, war genial. Mein Lüfter war bei 1% noch nie so langsam!

Zudem gibt's den Fan-Kickstart der von 0% aus beim ablaufen hilft.

Mir gefällt natürlich nicht, dass man alles Hardcoded in der config einstellen muss. Darum bekommt der Mod Menü und Eeprom Support für Frequenz, min und max.

LG
RF2000
Firmware Mod 1.45.00.Mod - geht SD wieder 100%?

Bitte 1.42.17 bis 1.42.21 meiden!
SD-Druck mit der Community-FW <= 1.43.99 aktuell meiden.

Benutzeravatar
Nibbels
Developer
Developer
Beiträge: 2269
Registriert: Mi 17. Aug 2016, 17:01
Hat sich bedankt: 832 Mal
Danksagung erhalten: 597 Mal

Re: RF2000 Extruder Lüfter gehen nicht mehr

Beitrag #66 von Nibbels » Mo 25. Jun 2018, 23:02

Ich muss hier einen Doppelpost abliefern :prost: .
Diese ~3Herz Einstellung und das Stretchen der Lüfterkennlinie ist echt genial.
Bei mir sind 1%, 25%, 50%, 75%, 100% am Ton des Lüfters unterscheidbar geworden.
An dieser Stelle vielen Dank an RF1000 / Conrad!!
:danke:

Man sieht im Video natürlich den Community-Mod, weil ich nur damit die Frequenzen und Einstellwerte onTheFly während der Laufzeit ändern kann.

https://youtu.be/hM6Cu_R9r98

Generell hat der Community-Mod (development) nun mindestens den Stand der offiziellen RF.01.42. Die Einstellbarkeit dieser Lüfterparameter habe ich heute Abend noch einmal überarbeitet (und auch die variablen schöner benannt/configuration aufgeräumt).
Die Konfiguration und PWM-Einstellungen des Part-Fans sind nun strikt von denen optional benutzter Hotend/Extruder-Kühler getrennt.

Der RF1000 wird als Standard wie bisher bei 15Herz initialisiert. Der RF2000 bei 3.8Herz und sollte jemand als erste Person überhaupt die Firmware auf dem RF2000v2 installieren und testen, so wird der Lüfter genau so initialisiert wie Conrad das bei der 1.42 macht. Also 3 Hz und dieselben Grenzwerte.

Ich kann nun endlich im Slicer die Lüfterkennlinien nutzen.
Und ich werde für z.B. ASA-Drucke wieder ganz leichte Luftströme einstellen können. Das war eine meiner letzten ungelösten Baustellen.
:10punkte:

LG
RF2000
Firmware Mod 1.45.00.Mod - geht SD wieder 100%?

Bitte 1.42.17 bis 1.42.21 meiden!
SD-Druck mit der Community-FW <= 1.43.99 aktuell meiden.


Zurück zu „Extruder“