RF500: PT100 statt 100K-Termistor für E3D Hotend?

Hier geht es ausschliesslich um die Extruder und Kühlung des Filamnts des RF500. Fragen und Probleme sowie Verbesserungen können hier diskutiert werden
Benutzeravatar
AtlonXP
Prof. Dr. des 3D-Drucks
Prof. Dr. des 3D-Drucks
Beiträge: 1941
Registriert: So 15. Nov 2015, 20:55
Hat sich bedankt: 521 Mal
Danksagung erhalten: 354 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #11 von AtlonXP » Mo 23. Dez 2019, 23:01

Erst einmal Danke plastiker,
ich versuche das Ganze zu verstehen.

In deiner FW Tabelle ist angegeben, dass ein 4k7 Ohm Widerstand als Pullup Standard gilt.
Einen echten Pullup, findet man an meiner Lichtschranke, aber hier sehe ich das anders.
Ich habe mir nun die Mühe gemacht und den Schaltplan vom RF1000 und deinem vom RAMPs 1.4,
ordentlich und nebeneinander darzustellen.

Schaltplan RF1000 zu RF500.jpg


Meine Vermutung, wie der Pullup Wiederstand eingepflegt sein sollte ist, ist falsch.

Wenn ich nichts übersehen habe, sind beide Schaltungen identisch.
Lediglich der Widerstand mit 33K Ohm, ist nur in der RFX000 Klasse zusätzlich eingepflegt.
Die 100 Fache Kapazität vom Kondensator (RAMPS) spreche ich nur an und verrechne es mit den 33K Ohm.

Vielleicht hat C… das so gemacht, das der A/D Wandler vom Mega 2560 geschützt ist,
wenn wieder einmal das V2 abkackt und eventuell ein Kurzschluss 24V auf der Thermistor Leitung entsteht.

Das hat aber zur Folge, dass wir wegen den 33KOhm, eine zusätzliche lineare Abweichung haben.
Es gilt nun die Thermistor Tabellen genau anzuschauen, ob dort die 33K Ohm kompensiert werden.
Oder auch irgendwo drum rum?

Da wir auf beiden Platinen den MEGA 2560 haben, gehe ich auch von denselben A/D Wandlern aus.

LG AtlonXP
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
plastiker
Elite 3D-Drucker
Elite 3D-Drucker
Beiträge: 523
Registriert: So 21. Sep 2014, 17:42
Hat sich bedankt: 76 Mal
Danksagung erhalten: 81 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #12 von plastiker » Do 26. Dez 2019, 21:36

Hallo AtlonXP,
Danke für Deine Analyse bzgl. A/D-Wandler. Werde beim PID-Tuning mal eine Kontrollmessung bzgl. Düsentemperatur versuchen.

Ich muss leider sagen, dass das Original-E3D Gold Editon Kit auch nicht ganz das hält, was es verspricht:
- Kabelbruch des "besser geschützten" Thermistors (bloß nicht irgendwo festbinden das Thermistorkabel.... :dash: )
- der transparente Lüfter sieht schön aus, ist aber VIEL zu laut und läuft nur bei max. Spannung (FW -> speed: 255) an mit dem zusätzlichen Fan Extender am RAMPS :sauer: ; verwende jetzt wieder den Anycubic Lüfter, der schon bei speed 200 anläuft und etwas leiser läuft. Die leisen Sunons laufen am Extender leider gar erst nicht an, auch nicht bei max. Startspannung (alle drei Lüfter sind DC12V und ca. 0.1A, scheinen aber sehr unterschiedlich im Anlaufverhalten zu sein...?!)
=> frage mich, wieviel Luftstrom man bis max. ca. 280°C überhaupt braucht am E3D Hotend?
- neben dem Lüftertausch musste ich auch noch das Endstop X -Kabel des RF500 tauschen - ebenfalls Kabelbruch :dash: :dash: :dash:
- die mitgelieferte Heizpatrone der orinal E3D Gold Edition ist NUR 30W, das ist ziemlich träge. Dachte schon, das liegt am Thermistor. Also lieber 'ne 40W reingebaut.
- trotzt sorgfältigem Zusammenbau Düse sofort verstopft, kommen nur Bröckchen raus. Trotz Düsenreinigung per Reinigungsnadel. :dash:
Morgen baue ich das Dinge wieder auseinander, irgendwo dran muss es doch liegen? Heiß genug wird das Ding, selbst wenn der Thermistor 3 Kelvin oder so daneben messen sollte. :blink:
VG, heute mal frustiger Plastiker
RF500-Bausatz, div. Modifikationen/Verbesserungen (E3D, NOT-AUS, TMC2100-Stepper Driver, RAMPS + FanExtension, DDP, Frontdoor, LED-Beleuchtung, Elektronik-Gehäuse mit Lüftern, Filament-Kammer, Einhausung,..)

Benutzeravatar
anwofis
Donator
Donator
Beiträge: 177
Registriert: Di 5. Mär 2019, 12:06
Hat sich bedankt: 47 Mal
Danksagung erhalten: 98 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #13 von anwofis » Do 26. Dez 2019, 22:18

@plastiker:

e3D-Gold: hab gerade geschaut, das Ding ist aber Teuer o_O

Die Patronenthermistoren sind sehr empfindlich - hab da auch schon 2-3 kaputt gemacht :/

Die speziellen e3D-Heizpatronen sind auch nicht der Bringer - hab' da auch eine drin.
Weiß gar nicht was da so besonders sein soll?

v6-gold gibt's auch aus China :p : https://de.aliexpress.com/item/32907697688.html

-

Was willst du überhaupt drucken @280°C: Polycarbonat?
Wundert mich eigentlich, dass die Düse verstopft. Bei mir ist nur ein kleiner 5V 30mm Lüfter dran am v6 und
der packt das bei Raumtemperatur locker. Hab' da eigentlich keine Probeme. Vllt. erstmal mit PLA oder PET testen?
Ist der Düsendurchmesser richtig gewählt?

Grüße,
anwofis

Benutzeravatar
AtlonXP
Prof. Dr. des 3D-Drucks
Prof. Dr. des 3D-Drucks
Beiträge: 1941
Registriert: So 15. Nov 2015, 20:55
Hat sich bedankt: 521 Mal
Danksagung erhalten: 354 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #14 von AtlonXP » Do 26. Dez 2019, 22:28

Hallo plastiker,
ich frage mich warum du Probleme hast mit dem Lüfter.

Der Lüfter wo das Hot End kühlen soll, den würde ich direkt auf Trumpf AS vom Netzteil klemmen.
Du fährst doch mit 12V?

Seit meiner Bauteillüfter Reparatur, habe ich auch eine Versorgungspannung von 12V in meinem RF1000.
Sollte die Drehzahl zu hoch sein, werde ich einfach einen berechneten Widerstand davor schalten.
Ich schätze 80% Leistung passt immer.

Schau mal in deinen FW Innereien nach, ob du dort etwas findest über die PWM Frequenz.
Der kleine Bauteillüfter vom RF1000 mag die 16,2 Hz am liebsten.
Vielleicht hast du dort auch eine Schraube zum Drehen und Testen. :developer:

LG AtlonXP

Benutzeravatar
AtlonXP
Prof. Dr. des 3D-Drucks
Prof. Dr. des 3D-Drucks
Beiträge: 1941
Registriert: So 15. Nov 2015, 20:55
Hat sich bedankt: 521 Mal
Danksagung erhalten: 354 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #15 von AtlonXP » Fr 27. Dez 2019, 13:10

Hallo plastiker,
mit welcher FW (Marlin oder Repetier) arbeitest du?

Nibbels hat mir endlich auf meine PN geantwortet und
leider nur die einfachen Fragen beantwortet.

Wenn du mit Repetier arbeitest, dann schau dir unbedingt diesen Link an:
viewtopic.php?p=20819#p20819

Hier sind Probleme behandelt über Repetier FW und ein paar enthaltene Fehler.

Aus diesem Beitrag leide ich ab, dass die Thermistor Tabellen so gut wie identisch sind.
Die 33K Ohm am RFX000, müssen irgendwo anders verrechnet werden.

LG AtlonXP

Benutzeravatar
plastiker
Elite 3D-Drucker
Elite 3D-Drucker
Beiträge: 523
Registriert: So 21. Sep 2014, 17:42
Hat sich bedankt: 76 Mal
Danksagung erhalten: 81 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #16 von plastiker » Fr 27. Dez 2019, 13:19

Hallo Zusammen,
also Polycarbonat bzw. 280°C wäre eine Option; aktuelle verdrucke ich nur PETG bei 240°C. Mir ging es nur darum den aktuellen Temperaturbereich für mein E3D anzugeben, also unterhalb 300°C - da sollte der Heatsink genügend aber auch nicht zu viel Kühlluft bekommen.
Denke auch, dass ca. 80% Speed bei erträglicher Lautstärke genügen sollten. Es soll halt nicht zu viel abkühlen aber auch nicht überhitzen.

Ich nutze den RRD-Fan-Extender für's RAMPS über den PWM Ausgang (unterer PIN). So kann man in der Firmware eine Temperatur vorgeben, ab der der "Nerv"-Lüfter erst anspringen soll. Aktuell bei mir ab 50°C, vorher brauchst doch keine Kühlluft - man will ja aufheizen.
Und die Speed 0-255 (0 = AUS, 255=MAX Speed) ist halt vorgebbar für den Lüfter. Stelle ich somit auf ca. 80% Speed ein (ANYCUBIC: 200).

// @section extruder

// Extruder cooling fans
// Configure fan pin outputs to automatically turn on/off when the associated
// extruder temperature is above/below EXTRUDER_AUTO_FAN_TEMPERATURE.
// Multiple extruders can be assigned to the same pin in which case
// the fan will turn on when any selected extruder is above the threshold.
#define EXTRUDER_0_AUTO_FAN_PIN 6 // PIN-Belegung von -1 auf 6 fuer RRD-Fan Extender_PWM-Luefter (HOTEND COOLING E3D SINGLE-Extruder)
#define EXTRUDER_1_AUTO_FAN_PIN -1
#define EXTRUDER_2_AUTO_FAN_PIN -1
#define EXTRUDER_3_AUTO_FAN_PIN -1
#define EXTRUDER_AUTO_FAN_TEMPERATURE 50 // ab 50 grad celsius schaltet Hotend-Luefter ein; NORMAL 50, TESTBETRIEB 30
#define EXTRUDER_AUTO_FAN_SPEED 255 // == full speed (FUER ANYCUBIC FAN genuegt 200, FUER E3D GOLDEN EDITION TRANSPARENT FAN XYJ12B30H10 DC12V 0.10A sind 255 !!!erforderlich!!! )


Bloß, dass eben nicht alle Lüfter unterhalb MAX Speed anspringen, warum auch immer. Das habe ich bei dem RRD-Platinchen nie ganz verstanden.
Jedenfalls läuft der ANYCUBIC Fan schon bei 200, der "Originale" E3D (transparente) Fan erst bei 255 an. Nicht mal bei bei 250 klappt es.

Klar, ich könnte auch direkt an die 12V gehen (über den 12V-PIN des RAMPS wird der RRD gespeist), dann wird der Lüfter MAX-Speed laufen und das permanent. (wobei mir da gerade einfällt, dass ich da zumindest die leisen SUNON-Lüfter mal dirkekt dran klemmen könnte....Wenn davon ein LEISER Lüfter permanent läuft, auch bei MAX speed, hätte ich ja kein Problem...muss bloß schauen, wie denn die richtige PIN-Belegung beim RAMPS dann wäre?)

Von einer PWM-Frequenz steht da nichts in der FW. @AltonXP: Wie sähe das aus? Hast Du evtl. ein Bsp.? Dann könnte ich danach mal suchen und mir evtl. in den RRD-Code reinfummeln.

Gestern war ich noch mit der Reinigungsnadel im E3D-Hotend, ließ sich problemlos reinschieben in die Düse + Stück weit ins Hotend.
Trotzdem kommt nix richtig raus. Muss das also wieder alles schön Zerlegen.

VG
Platiker
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
RF500-Bausatz, div. Modifikationen/Verbesserungen (E3D, NOT-AUS, TMC2100-Stepper Driver, RAMPS + FanExtension, DDP, Frontdoor, LED-Beleuchtung, Elektronik-Gehäuse mit Lüftern, Filament-Kammer, Einhausung,..)

Benutzeravatar
AtlonXP
Prof. Dr. des 3D-Drucks
Prof. Dr. des 3D-Drucks
Beiträge: 1941
Registriert: So 15. Nov 2015, 20:55
Hat sich bedankt: 521 Mal
Danksagung erhalten: 354 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #17 von AtlonXP » Fr 27. Dez 2019, 14:31

Hallo plastiker,
mit welcher FW arbeitest du?
Hier ein Auszug aus einer älteren FW des RF1000 (Repetier Host configuration.h).

#define HEATER_PWM_SPEED 0 // How fast ist pwm signal 0 = 15.25Hz, 1 = 30.51Hz, 2 = 61.03Hz, 3 = 122.06Hz

Wo das allerdings verbastelt ist, kann ich im Moment nicht sagen.

Der SUNO mag kein PWM Signal.
Man könnte noch einen fetten Kondensator >= 1000 Mikrofarad parallel zum Lüfter schalten.
Das glättet etwas, das PWM Signal.

LG AtlonXP

Benutzeravatar
plastiker
Elite 3D-Drucker
Elite 3D-Drucker
Beiträge: 523
Registriert: So 21. Sep 2014, 17:42
Hat sich bedankt: 76 Mal
Danksagung erhalten: 81 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #18 von plastiker » Sa 28. Dez 2019, 11:33

Das Problem ist quasi ein doppeltes "Clogging",also Düse war verstopft aber auch das heatbreak bin in den oberen Bereich hinein... :sauer:

Das E3D Gold kommt ohne den typischen Sechskant-Pneu-Fit Fixierer aus Metall daher, der ordenlich stramm den PTFE-Schlauch festhält.
Hier hat man nur einen schwarzen-Klemmer der eingeschoben wird in die verkleinerte Bohrung. Damit soll es das Capricorn-Tubing halten,
weist aber ein axiales Spiel auf. S. Foto. Blöderweise hatte ich den blauen Sicherungsclip vergessen bzw. war mir davon gepurzelt und wurde übersehen :dash:

Aber selbst damit, Tubing GANZ bis aufs Heatbreak eingeschoben + Sicherungsclip aufgeschoben ließ sich der Heatbreak immer noch um 1/4 bis 1/4 umdrehung gegen das Tubing einschrauben, habe es im demontierten Zustand getestet. Wenn das Hotend komplett montiert ist, also Heatbreak gegen Düse verschraubt, geht das natürlich nicht mehr. Und das Tubing schiebt man ja immer erst zum Schluß am Drucker ein. Es ensteht also immer ein kleiner Spalt zw. Tubing und Heatbreakanschlag (unten in der oberen Heatbreakbohrung). Da kann sich ggf. also Material reinschieben.

Mein Fazit: Fehlkonstruktion des Herstellers! Ist eben nicht alles GOLD was glänzt. Aber wieso funktioniert es dann bei anderen Leuten so perfekt?

Hoffe, das ist wenigstens die Hauptursache fürs Clogging. Bis ich dahinter kam war das ganze Hotend zum 2ten Mal dicht... :dash: :sick:
Muss mir da mal was überlegen.

LG, Plastiker
Tubing_axiales Spiel.JPG
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
RF500-Bausatz, div. Modifikationen/Verbesserungen (E3D, NOT-AUS, TMC2100-Stepper Driver, RAMPS + FanExtension, DDP, Frontdoor, LED-Beleuchtung, Elektronik-Gehäuse mit Lüftern, Filament-Kammer, Einhausung,..)

Benutzeravatar
anwofis
Donator
Donator
Beiträge: 177
Registriert: Di 5. Mär 2019, 12:06
Hat sich bedankt: 47 Mal
Danksagung erhalten: 98 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #19 von anwofis » Sa 28. Dez 2019, 14:32

@plastiker:

Also den Clip mache ich auch immer drauf, aber eigentlich verstopft ein v6 nicht einfach so?

Ist das auch sicher ein Vollmetall-v6 mit 1.75 mm Heatbreaks ohne PTFE Inliner?
Da wird das Filament ja erst im Heatblock-Bereich weich - oben in der Heizsperre ist es noch fest.
Es verstopft eigentlich nur, wenn der Hotendkühler ausfällt und die Wärme des Heizblockes nach oben "wandert" und das Filament
im Zuführbereich aufschmilzt.

Würde das Ding sonst so wie es ist wieder zurückschicken und ein normales Vollmetall v6 mit gehärteter Düse einbauen...

Benutzeravatar
AtlonXP
Prof. Dr. des 3D-Drucks
Prof. Dr. des 3D-Drucks
Beiträge: 1941
Registriert: So 15. Nov 2015, 20:55
Hat sich bedankt: 521 Mal
Danksagung erhalten: 354 Mal

Re: RF500: PT100 statt 100K-Termistor für E3D Hotend?

Beitrag #20 von AtlonXP » Sa 28. Dez 2019, 15:39

Hallo plastiker,
ich fürchte, so einfach geht das nicht.

Der Retrakt sollte bei einem Ganzmetall Hot End sehr kurz sein < 0,8mm.
Vermutlich musst du diesen erst rausmessen (Spiel in der Bowden Zuleitung) und verrechnen.
Mit PETG und eventuell PLA könnte es Probleme geben.

Vom Heat Break, gibt es so viele Ausführungen:
https://de.aliexpress.com/item/32967905 ... lsrc=aw.ds

Dann gibt es die Dinger noch in verschieden Materialausführungen.
Auch noch mit verschieden Beschichtungen. (MaPa oder TwinClad XT Beschichtung).

PTFE ist bis 258C° mein Favorit.
Auch hier kann eine Beölung noch gut sein.
Ich schließe das aus meinen Erfahrungen, mit dem V2.

Demnächst werde ich mich mit diesem Thema auch rumschlagen.
Ich habe mir so ‘n billigen V6 China bolzen, zum Testen bestellt.
Vielleicht schafft er es noch dieses Jahr zu mir. ;-)

Ich vermute, es gibt nicht die Konfiguration des V6.
Darum werde ich verschieden ausprobieren.

Zum Trost, schau mal bei Peter KA nach, da hat es auch nicht auf Anhieb hingehauen.

LG AtlonXP


Zurück zu „Extruder“