Z-Kompensation funktioniert nicht

Hier gehts um die Elektronik des RF1000. Damit sind Kabel, Platinen, Endschalter und das Display gemeint.
Benutzeravatar
Husky
Globaler Moderator
Globaler Moderator
Beiträge: 259
Registriert: Mi 10. Sep 2014, 11:56
Danksagung erhalten: 17 Mal

Re: Z-Kompensation funktioniert nicht

Beitrag #11 von Husky » Do 25. Sep 2014, 14:51

Grundsätzlich besteht die Möglichkeit immer, aber den G-Code hat Tobi gestern schon geschrieben und der war OK.
Der Log wird auch während des druckens über den Repetier-Host angezeigt, sollte ein Fehler beim ausführen des Code auftreten kommt eine Rückmeldung. Gestern war es nur schon recht Spät, daher hab ich das noch nicht mit Tobi geprüft. Das ist einer nächsten Schritte. Erstmal möchte ich wissen ob der Drucktisch wirklich gerade ist und der auch Abstand passt.

Ich vor kurzem ein ähnliches Problem zumindest in soweit das die Z-Komp. nicht ging. Da hab ich auch nicht geklaubt das ein leichtes verdrehen einer Spindel soviel ausmacht. Nur kam bei mir noch ein defekt an der Platine hinzu. Aber man lernt ja nie aus.
Upgrades: Dual Extruder, Platinenkühlung, Not-Aus, besserer Z-Endschalter, Filamentführungsröhrchen, Dauerdruckplatte, Schleppketten erhöhung, Schnellwechselsystem, Fräse, Einhausung.

„Probleme kann man niemals mit derselben Denkweise lösen, durch die sie entstanden sind.“
Albert Einstein

Benutzeravatar
riu
Administrator
Administrator
Beiträge: 1248
Registriert: Do 4. Sep 2014, 23:48
Wohnort: Düsseldorf
Hat sich bedankt: 43 Mal
Danksagung erhalten: 137 Mal
Kontaktdaten:

Re: Z-Kompensation funktioniert nicht

Beitrag #12 von riu » Do 25. Sep 2014, 14:55

Naja es war ja nur zu einem Zwecke. Die Messergebnisse in ein annehmbares Delta zu bringen. War nur ein Vorschlag. Ich bin immer ein Fan von Reproduktion. Erst wenn ich immer die Gleichen ausganswerte habe kann ich was einstellen. Vorher ist das wie auf einer Balkenwippe mit nem Fass balancieren :P

Gruss,
Udo

Benutzeravatar
Pedritoprint
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 116
Registriert: Mo 15. Sep 2014, 15:19
Wohnort: Wängi/TG [CH]
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Re: Z-Kompensation funktioniert nicht

Beitrag #13 von Pedritoprint » Do 25. Sep 2014, 15:30

riu hat geschrieben:Hallo zusammen.

Also bei mir zeigen die Pfeile auch auf die Heizplatte. Das bedeutet dass die Kraft von unten wirkt. Also entgegen der Pfeile wirkende Kraft lässt die Digits steigen.
Ich denke aber nicht das dies ein Problem darstellt.


Da geh ich mit Dir einig, nur, bei der Verdrahtung können die Stecker ja gar nicht verdreht montiert werden (4polig mit Verdrehschutz), und daher schilderte ich meine Beobachtung beim Hantieren mit den Dehnungsmessstreifen.
(X7 auf der Hauptplatine bezeichnet mit DMS)
Peter
P.S. Es ist ja alles Relativ, die SW wirds richten :clapping:

Benutzeravatar
riu
Administrator
Administrator
Beiträge: 1248
Registriert: Do 4. Sep 2014, 23:48
Wohnort: Düsseldorf
Hat sich bedankt: 43 Mal
Danksagung erhalten: 137 Mal
Kontaktdaten:

Re: Z-Kompensation funktioniert nicht

Beitrag #14 von riu » Do 25. Sep 2014, 15:33

Ich habe mir mal die Mühe gemacht und einen von Tobis, Scans geordnet. So kann man auch was erkennen.

[code:2biqvuua]
23:59:52.611 : ;2 ; 0;575;1341;2107;2873;3639;4405;5171;5937;6703;7469;8235;9001;9767
23:59:52.611 : ;0 ;-56;-38; -18; -7; 5; 17; 27; 31; 13; -30; -73;-135;-176;-176
23:59:52.611 : ;1150;-54;-37; -13; 0; 8; 21; 30; 30; 14; -25; -69;-133;-175;-176
23:59:52.611 : ;1916;-50;-36; -7; 10; 16; 30; 34; 29; 16; -16; -61;-129;-174;-174
23:59:52.611 : ;2682;-42;-30; -2; 16; 30; 43; 41; 37; 25; -5; -51;-121;-165;-174
23:59:52.611 : ;3448;-32;-21; 8; 30; 47; 58; 55; 46; 32; 7; -41;-112;-154;-156
23:59:52.611 : ;4214;-19;-10; 23; 50; 64; 71; 71; 59; 40; 18; -30;-100;-141;-152
23:59:52.611 : ;4980; -6; 6; 37; 63; 78; 84; 86; 78; 55; 27; -19; -88;-127;-130
23:59:52.611 : ;5746; 2; 19; 50; 72; 85; 95; 99; 84; 61; 34; -13; -81;-120;-124
23:59:52.611 : ;6512; 10; 29; 61; 80; 90; 101; 104; 89; 67; 37; -11; -79;-120;-116
23:59:52.611 : ;7278; 17; 35; 67; 86; 94; 103; 105; 93; 74; 41; -9; -82;-126;-124
23:59:52.611 : ;8044; 20; 36; 70; 89; 94; 106; 105; 93; 77; 45; -8; -85;-128;-128
23:59:52.611 : ;8810; 20; 20; 52; 88; 90; 98; 114; 96; 90; 64; 26; -42;-128;-128
[/code:2biqvuua]

Die Angaben sind ja in Steps und 1 mm hat ja laut Firmware was um die 38,6 steps auf X und X und 640 auf Z

Erste Zeile (Y -Achse) und Erste Spalte (X-Achse) sind also #steps/38.6 = mm
Die steps in der Matrix sind #steps/640 = mm Z-Versatz der Platte.

Werte ins Minus gehen phisikalisch nach oben auf der Platte, und vice versa.

Wen ich das jetzt grafisch darstellen würde, würde ich sagen dass die Platte von vorne gesehen, von der Mitta am leicht nach hinten links komplett durchhängt.Die Ränder, bis auf hinten links, stehen nach oben. Das sieht für mich aus, als ob die Platte die vermessen wurde total Buckelig ist. Da kannste Wasser reinfüllen.

Man bechte:

[code:2biqvuua]
23:59:52.611 : ;2 ; 0;575;1341;2107;2873;3639;4405;5171;5937;6703;7469;8235;9001;9767
23:59:52.611 : ;8810; 20; 20; 52; 88; 90; 98; 114; 96; 90; 64; 26; -42;-128;-128
[/code:2biqvuua]

Alleine das hier (auf 4404 steps 114 und auf 9001-9767 steps -128) macht schon 0.38 mm an Höhenunterschied auf Z aus. das geht garnicht.

:idea: Fahr in den Baumarkt, kauf dir nen billigen 3 mm Spiegel für 5 EUR einen Glasschneider für 5 EUR und schneide dir eine Glasplatte zurecht. Klemm die mit Dokumentklemmen oder solchen Spannzangen auf die Platte die du da gerade hast und mach mal nen Headbed Scan. Dann einen Druck. Du wirst sehen alles ist gut.

So genug Theorie. Ich will taten sehen :clapping:

Gruss,
Udo

Benutzeravatar
Pedritoprint
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 116
Registriert: Mo 15. Sep 2014, 15:19
Wohnort: Wängi/TG [CH]
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Re: Z-Kompensation funktioniert nicht

Beitrag #15 von Pedritoprint » Do 25. Sep 2014, 16:04

Diese Mühe habe ich mir auch gemacht, das sieht glaub ich noch viel schlimmer aus, zum Glück drucke ich vorne rechts in der Ecke nicht!! :(
Ansonsten keine Problem..
Peter
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
Plastikschmied
Themenstarter
Profi 3D-Drucker
Profi 3D-Drucker
Beiträge: 314
Registriert: Sa 20. Sep 2014, 15:14
Hat sich bedankt: 3 Mal
Danksagung erhalten: 8 Mal

Re: Z-Kompensation funktioniert nicht

Beitrag #16 von Plastikschmied » Do 25. Sep 2014, 16:31

Hab jetzt erstmal alles grob uberflogen. ... less nachher nochmal genau. Der Spiegel hält
160° aus ?
Da mach ich das.. wie bekomme ich die dann gerade drauf ? Einfach drauf legen und fest klemmen ? Research dann erstmal der z Kompensator . Wenn er mal funktioniert.

Das ist übrigens eine neue 10 mm alluplatte. .. anscheinend gibt's nur Müll angedreht :/

Werte
etc folgen morgen
schon mal. !

Benutzeravatar
Husky
Globaler Moderator
Globaler Moderator
Beiträge: 259
Registriert: Mi 10. Sep 2014, 11:56
Danksagung erhalten: 17 Mal

Re: Z-Kompensation funktioniert nicht

Beitrag #17 von Husky » Do 25. Sep 2014, 16:37

Deshalb wäre jetzt als vergleich die manuell gemessenen Werte interessant.
Dann weis man auch ob die Wägezellen noch richtig messen.
Da bei einem anderen Scan das rauskam:
[code:1juuh3uu]
;23:58:20.239 : ;2;0;575;1341;2107;2873;3639;4405
23:58:20.239 : ;0;0;0;0;0;0;0;0
23:58:20.239 : ;1150;0;6;30;28;106;104;30
23:58:20.239 : ;1916;0;6;36;50;108;126;58
23:58:20.239 : ;2682;0;38;42;68;130;144;72
23:58:20.239 : ;3448;0;46;40;86;128;138;84
23:58:20.239 : ;4214;0;32;62;88;146;156;102
23:58:20.239 : ;4980;0;46;64;110;140;174;114
23:58:20.239 : ;5746;0;64;82;108;142;176;142
23:58:20.239 : ;6512;0;66;100;130;144;178;160
23:58:20.239 : ;7278;0;84;102;132;150;176;166
23:58:20.239 : ;8044;0;86;100;134;136;178;168
23:58:20.239 : offset = 178
[/code:1juuh3uu]
Hier sieht das wieder ganz anders aus.
Morgen haben wir ja den Vergleich.

Gruß,
Husky
Upgrades: Dual Extruder, Platinenkühlung, Not-Aus, besserer Z-Endschalter, Filamentführungsröhrchen, Dauerdruckplatte, Schleppketten erhöhung, Schnellwechselsystem, Fräse, Einhausung.



„Probleme kann man niemals mit derselben Denkweise lösen, durch die sie entstanden sind.“

Albert Einstein

Benutzeravatar
riu
Administrator
Administrator
Beiträge: 1248
Registriert: Do 4. Sep 2014, 23:48
Wohnort: Düsseldorf
Hat sich bedankt: 43 Mal
Danksagung erhalten: 137 Mal
Kontaktdaten:

Re: Z-Kompensation funktioniert nicht

Beitrag #18 von riu » Do 25. Sep 2014, 16:40

Hi Tobi.

Die Aluplatten MÜSSEN plangefräst werden. Die Aluplatten die man so bekommt haben meisten eine Toleranz von +-0,5mm das ist im Groben 1mm das ist zuviel.

Der Spiegel hält das locker aus. Ja einfach draufklemmen fertig. Dann klappt auch. Aber nur vorne und hinten an einer stelle sonst biegst du den auch wieder. Bei deinem Scan würde ich sagen vorne links und hinten rechts. Das ist am wenigsten Gefälle. Einfach mir solchen klammern die ich auf den Drucker gelegt habe aufklemmen. Eine von den Beiden (Livecam)

Bin jetzt mal weg :popcorn:

Oo
Globaler Moderator
Globaler Moderator
Beiträge: 474
Registriert: Fr 5. Sep 2014, 19:08
Hat sich bedankt: 24 Mal
Danksagung erhalten: 35 Mal

Re: Z-Kompensation funktioniert nicht

Beitrag #19 von Oo » Do 25. Sep 2014, 16:49

Hi,

hab zwar nicht gesehen was du für welche hast aber normal sind das Maul Klammern,
wenn ihr die richtige Bezeichnung sucht.

Benutzeravatar
Pedritoprint
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 116
Registriert: Mo 15. Sep 2014, 15:19
Wohnort: Wängi/TG [CH]
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Re: Z-Kompensation funktioniert nicht

Beitrag #20 von Pedritoprint » Do 25. Sep 2014, 19:51

Nachdem ich über das Resultat meines "Head-Bed-Scan" erschrocken bin, habe ich meinen Tisch neu ausgerichtet (Spindel rechts um "2 Zähne" nach unten gedreht)
Es sieht nun viieeel besser aus, :yes: aber auch hier, die Keramikplatte ist recht verzogen.
Gruss Peter
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.


Zurück zu „Elektronik“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste