Nichts geht mehr nach einem Firmware Update Versuch Post ist gelöst/erledigt

Firmware Veröffentlichungen und Einstellungen können hier angekündigt und diskutiert werden.
deathworm
Themenstarter
Anfänger
Anfänger
Beiträge: 7
Registriert: Mo 10. Dez 2018, 13:29
Danksagung erhalten: 1 Mal

Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #1 von deathworm » Mi 9. Jan 2019, 19:29

Hi,

also ich hatte noch die Original Auslieferungsfirmware drauf. 1.01 oder so. Nun habe ich versucht nach Anleitung diesen zu Updaten. Also Arduino SOftware 1.65 und den aktuellen Stavble Repetierhost runtergeladen. Auf 2560 etc alles wie in der ANleitung eingestellt. Beim kompilieren kamen Fehlermeldungen. Ich habe dann mehrmals auf Upload gedrueckt. Habe den Comport in den Systemeinstellungen geaendert und auch als Admin das ganze ausgefuehrt. Ploetzlich ging das Licht beim RF2000 aus und beim naechsten Neustart des Druckers passiert nun garnichts mehr. Im Display kommen nur noch Vierecke in beiden Zeilen.

Ich kann mich auch nicht mehr mit SImplify3D oder so drauf verbinden.

Platine defekt? :(

zero K
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 164
Registriert: Mi 6. Dez 2017, 13:17
Hat sich bedankt: 2 Mal
Danksagung erhalten: 57 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #2 von zero K » Mi 9. Jan 2019, 21:03

Moin Deathworm

Erkennt Dein Rechner die angeschlossene Hardware?
Wird das Motherboard in der Arduino-IDE erkannt?
Hast Du in der configuration.h Deinen Drucker auskommentiert?
Bist Du sicher, dass Du auch für die neue Firmware diese steinalte Arduino-IDE benötigst?

Gruß zero K

deathworm
Themenstarter
Anfänger
Anfänger
Beiträge: 7
Registriert: Mo 10. Dez 2018, 13:29
Danksagung erhalten: 1 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #3 von deathworm » Mi 9. Jan 2019, 21:50

Guten Abend und VIelen Dank fuer deine Antwort,


Erkennt Dein Rechner die angeschlossene Hardware?
-> Also wenn ich den Drucker per USB Verbinde, wird eine USB SERIAL Verbindung im Geraete Manager hinzugefuegt. Ist das schon Mal ein gutes Zeichen?

Wird das Motherboard in der Arduino-IDE erkannt?
-> Wo sehe ich das?

Hast Du in der configuration.h Deinen Drucker auskommentiert?
-> Nein. Diese Info habe ich weder in dem Thread zur AKtualisierung noch in der offiziellen Anleitung gefunden (Ich habe mir die Repetier original Firmware, keine Community FIrmware, runtergeladen)

Bist Du sicher, dass Du auch für die neue Firmware diese steinalte Arduino-IDE benötigst?
-> So steht es zumindest im Thread drin.
--> "Bitte nur mit der 1.6.5 arbeiten." viewtopic.php?f=7&t=68


Gruesse,

Sascha

zero K
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 164
Registriert: Mi 6. Dez 2017, 13:17
Hat sich bedankt: 2 Mal
Danksagung erhalten: 57 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #4 von zero K » Mi 9. Jan 2019, 23:52

Guten Abend Deathworm

Ob Dein Drucker in der Arduino-Ide angewählt ist siehst Du hier.
Werkzeuge.jpeg

Der Dateipfad sieht unter Windows vermutlich etwas anders aus.

Und so etwa sollte der erste Abschnitt in der Configuration.h für einen RF 2000 aussehen.
Configurationh.jpeg


In der Arduino-IDE am Häkchen oben links prüfen,
mit dem Pfeil nach unten speichern
und zum Schluss mit dem Pfeil nach rechts auf den Drucker hoch laden.

Das dauert dann so zwei bis drei Minuten.

Auf welche Firmware und woher hast Du sie, möchtest Du denn aktualisieren?
(Vielleicht bin ich schon wieder im falschen Film mit meinen RF2kv2-Scheuklappen)

Gutes Gelingen
zero K
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
Nibbels
Developer
Developer
Beiträge: 2130
Registriert: Mi 17. Aug 2016, 17:01
Hat sich bedankt: 752 Mal
Danksagung erhalten: 500 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #5 von Nibbels » Do 10. Jan 2019, 02:11

Ja,

also die original Firmware kommt mit den neuen Arduinos nicht klar.
Der Mod hätte mit der alten nicht kompiliert.

Wir haben einen Bootloader auf der Platine, der normalerweise beim hochfahren "checkt" ob gerade eine Software aufgespielt werden will.
Der USB-Seriell-Chip läuft immer übers USB-Kabel. (Der kann also funktionieren, obwohl der Drucker eigentlich aus ist.)
Der USB-Seriell-Chip kann einen Pin namens DTR wechseln, dann müsste der Drucker in den Reset gehen. So schickt Arduino meines wissens den Drucker in den Bootloader.
Du könntest testweise versuchen den Drucker genau dann anzuschalten, wenn der Programmer hochladen will. Evtl. hilft das. Ich hatte so mal ein selbstverschuldetes Watchdog-Loop-Problem wieder hinbekommen.

Einmal war einer hier, der meinte, er hätte irgendwie den Bootloader überschrieben bekommen. Das darf eigentlich nicht funktionieren, denn der Bereich müsste als schreibgeschützt markiert sein!

Wenn der Bootloader nicht mehr arbeitet, könnte man den AtMega2560 über die Programmer-Pins mit einem Bootloader flashen. Dafür muss man aber ziemlich genau wissen was man tut. Ich habe das noch nie gemacht:
viewtopic.php?f=67&t=2324&p=24267&hilit=Bootloader#p24265
Ich habe von dem Nutzer leider keine Rückmeldung mehr bekommen.

LG
RF2000
Firmware Mod 1.43.85.Mod

Bitte 1.42.17 bis 1.42.21 meiden!
SD-Druck mit der Community-FW aktuell meiden.

deathworm
Themenstarter
Anfänger
Anfänger
Beiträge: 7
Registriert: Mo 10. Dez 2018, 13:29
Danksagung erhalten: 1 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #6 von deathworm » Do 10. Jan 2019, 22:23

Hallo!

"Und so etwa sollte der erste Abschnitt in der Configuration.h für einen RF 2000 aussehen."
ist bereits so erledigt, da ich direkt den RF2000 Ordner nehme.
Download kommt von hier: https://github.com/RF1000/Repetier-Firmware

"In der Arduino-IDE am Häkchen oben links prüfen,"
-> "Der Sketch verwendet 210.470 Bytes (82%) des Programmspeicherplatzes. Das Maximum sind 253.952 Bytes.
Globale Variablen verwenden 6.235 Bytes (76%) des dynamischen Speichers, 1.957 Bytes für lokale Variablen verbleiben. Das Maximum sind 8.192 Bytes.
Wenig Speicher verfügbar, es können Stabilitätsprobleme auftreten."

und zum Schluss mit dem Pfeil nach rechts auf den Drucker hoch laden.
-> "Wenig Speicher verfügbar, es können Stabilitätsprobleme auftreten.
avrdude: ser_open(): can't open device "\\.\COM8": Das System kann die angegebene Datei nicht finden.
avrdude: ser_drain(): read error: Das Handle ist ungültig.
Probleme beim Hochladen auf die Platine. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload ."

Und der Fehler kommt, egal ob ich den Drucker an oder aus habe.



-----

Der USB-Seriell-Chip läuft immer übers USB-Kabel. (Der kann also funktionieren, obwohl der Drucker eigentlich aus ist.)
-> Stimmt - erst beim an- bzw. ausstecken des USB Kabels geht der COM Port im Geraete Manager weg. Beim an- und ausschalten bleibt er bestehen.

Hört sich seeehr schwierig an. Aber sieht wohl aus, als ob es keinen anderen Ausweg mehr gibt, oder ?

PeterKa
Profi 3D-Drucker
Profi 3D-Drucker
Beiträge: 423
Registriert: So 7. Feb 2016, 11:04
Wohnort: Rinteln
Hat sich bedankt: 15 Mal
Danksagung erhalten: 196 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #7 von PeterKa » Do 10. Jan 2019, 22:49

Der Fehler ist eindeutig und hat reinweg nix mit dem RF zu tun. Dat Problem ist auf dem PC: Er kann den Com Port nicht öffnen. Da muß man dann mal in den Gerätemanager. Die Ursachen dafür sind leider sehr vielfältig. Zuerstmal würde ich es als Adminstrator versuchen,

PeterKa

zero K
Erfahrener 3D-Drucker
Erfahrener 3D-Drucker
Beiträge: 164
Registriert: Mi 6. Dez 2017, 13:17
Hat sich bedankt: 2 Mal
Danksagung erhalten: 57 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #8 von zero K » Do 10. Jan 2019, 23:22

Guten Abend Sascha
Die Meldung über den geringen Speicher muss Dich bei über 1,200 kb nicht beunruhigen.

Dieser Abschnitt scheint aber bedenklich.
Das sieht mir irgendwie wie ein gefakter Com-Port aus.

avrdude: ser_open(): can't open device "\\.\COM8": Das System kann die angegebene Datei nicht finden.
avrdude: ser_drain(): read error: Das Handle ist ungültig.
Probleme beim Hochladen auf die Platine. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload ."


Zeigt er doch dass in Deinen Betriebssystem des Rechners möglicherweise den FTDI-Treiber nicht korrekt eingerichtet ist.
Der FTDI-chip in Deinem Drucker vermittelt die Datenübertragung zwischen deinem Rechner und dem AVR Mega auf dem Mainboard Deines Druckers.

Unter Deinem Link zum Troubleshooting wirst Du unter anderen auf die FTDI-Homepage geleitet.
Win 2K war mein letztes Microsoftbetriebssytem - Bis auf die Tatsache dass es da einen Hardwaremanager gibt weiß ich nicht mehr viel davon.

Wenn ich meinen RF2kv2 anstöpsele erhalte ich von der Hardware Info meines Rechners folgende Ausgabe,

[45983.825171] usb 7-2: new full-speed USB device number 3 using uhci_hcd
[45984.043247] usb 7-2: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[45984.043262] usb 7-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[45984.043271] usb 7-2: Product: FT232R USB UART
[45984.043279] usb 7-2: Manufacturer: FTDI
[45984.043287] usb 7-2: SerialNumber: A506MX0D
[45984.053255] ftdi_sio 7-2:1.0: FTDI USB Serial Device converter detected
[45984.053304] usb 7-2: Detected FT232RL
[45984.055314] usb 7-2: FTDI USB Serial Device converter now attached to ttyUSB0


Ich müsste mir also den für mein Betriebssystem aktuellen Treiber für den FT232RL herunter laden.

Gruß zero K

Benutzeravatar
Nibbels
Developer
Developer
Beiträge: 2130
Registriert: Mi 17. Aug 2016, 17:01
Hat sich bedankt: 752 Mal
Danksagung erhalten: 500 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #9 von Nibbels » Fr 11. Jan 2019, 15:37

Der Vollständigkeit haltber, wenn mal jemand anders hier liest:

Sollte dein Drucker nach dem Flashen öfters piepen, hast du die RF2000-Firmware auf einem RF1000 installiert - oder umgekehrt. Piep Piep Piep ...

In deinem Fall würde ich mal einen anderen Rechner nehmen.
Oder prüfen, warum du schon bei COM8 angekommen bist. Du musst extrem viele alte Com-Treiber installiert haben, wenn Windows COM8 als Nummer nutzt. Notfalls die ganzen alten Treiber runterschmeißen und neu automatisch installieren lassen. Notfalls über den Hersteller gehen.

Die Baudrate sollte normalerweise 115200 sein.
(Stimmt das Gerücht mit 250000 bei uralten FIrmwares?)

LG
RF2000
Firmware Mod 1.43.85.Mod

Bitte 1.42.17 bis 1.42.21 meiden!
SD-Druck mit der Community-FW aktuell meiden.

Timo
Gelegenheitsdrucker
Gelegenheitsdrucker
Beiträge: 19
Registriert: So 22. Okt 2017, 02:30
Wohnort: Hannover
Hat sich bedankt: 7 Mal
Danksagung erhalten: 6 Mal

Re: Nichts geht mehr nach einem Firmware Update Versuch

Beitrag #10 von Timo » Fr 11. Jan 2019, 18:30

Nibbels hat geschrieben:Ich habe von dem Nutzer leider keine Rückmeldung mehr bekommen.


Du hast recht! :scham: Ich habe leider vergessen, mich zurückzumelden. Ich konnte den damaligen Fehler (Layerversatz) auch nicht eindeutig mit irgendeinem Ereignis in Verbindung bringen, daher hatte ich die Firmware einfach nochmal (auf meinem Ubuntu-Printserver) neu kompiliert und geflasht. Danach ging wieder alles und der Drucker läuft seitdem wieder einwandfrei.

In der Zwischenzeit bin ich durch ein anderes Projekt auf eine mögliche Ursache für das damalige Fehlverhalten gestoßen. Ich konnte das andere Projekt sporadisch nicht kompilieren, ohne erkennbaren Grund ist der Linker mit internem Error ausgestiegen. Eine kurze Recherche ergab, dass eine bestimmte Kombination aus Arduino IDE und Board Package auf Win10x64 Systemen zu Fehlern führt (beides aber jeweils relativ aktuell). Ein downgrade der Board-Packages hat den Fehler dann zuverlässig behoben. Eventuell hat dieser Bug auch mit meinem damaligen Problem zu tun, das ist aber reine Spekulation.

Das flashen des Bootloaders ist übrigens sehr unproblematisch. Mit einem Arduino nano geht das direkt aus der IDE.

Viele Grüße
Timo


Zurück zu „Firmware / Tweaks“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste