Probleme mit dem Heat Bed Scan

Hier geht es um die reine Hardware des RF1000. Bitte nutzt das "Forum durchsuchen" und die Kategorien. Wenn nicht klar ist wohin, dann in Sonstiges.
trilobyte
Themenstarter
Gelegenheitsdrucker
Gelegenheitsdrucker
Beiträge: 47
Registriert: So 25. Jun 2017, 21:57
Wohnort: lenggenwil
Hat sich bedankt: 6 Mal
Danksagung erhalten: 4 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #31 von trilobyte » Di 6. Nov 2018, 19:10

wenn ich den drucker einschalte und repetier host mit dem drucker verbinde kommt folgendes:
19:06:11.902 : OpenGL version:4.6.0 NVIDIA 411.63
19:06:11.902 : OpenGL extensions:(..)WGL_EXT_swap_control
19:06:11.902 : OpenGL renderer:Quadro K2000/PCIe/SSE2
19:06:11.902 : Using fast VBOs for rendering is possible
19:06:20.006 : Serieller Verbindungsfehler:System.IO.Ports.SerialErrorReceivedEventArgs
19:06:20.022 : Serieller Verbindungsfehler:System.IO.Ports.SerialErrorReceivedEventArgs
19:06:21.603 : Printer reset detected - initalizing
19:06:21.666 : start
19:06:21.666 : Info:External Reset
19:06:21.666 : Free RAM:1404
19:06:21.868 : N1 M110*34
19:06:21.868 : N2 M115*36
19:06:21.868 : N3 M105*36
19:06:21.868 : N4 M114*35
19:06:21.868 : N5 M111 S6*98
19:06:26.552 : start Watchdog
19:06:26.584 : setupForPrinting(): invalid active heat bed z matrix detected: 13
19:06:31.189 : N6 T0*60
19:06:31.298 : N7 M20*22
19:06:31.298 : FIRMWARE_NAME:Repetier_RF.01.42.22 COMPILED:Sep 30 2018 FIRMWARE_URL:https://github.com/RF1000community/Repetier-Firmware PROTOCOL_VERSION:1.0 MACHINE_TYPE:Mendel EXTRUDER_COUNT:1 REPETIER_PROTOCOL:3
19:06:31.298 : Printed filament:227.99m Printing time:2 days 22 hours 45 min
19:06:31.298 : N8 M80*19
19:06:31.298 : X:0.00 Y:0.00 Z:0.00 E:0.00
19:06:31.298 : N9 M105*46
19:06:31.298 : N10 M220 S100*80
19:06:31.298 : N11 M221 S100*80
19:06:31.313 : Begin file list
19:06:31.313 : N12 M111 S6*84
19:06:31.329 : End file list
19:06:31.329 : N13 T0*8
19:06:34.079 : N14 M105*18
19:06:37.141 : N15 M105*19
19:06:40.202 : N16 M105*16


da ist schon mal der error 13drin. wieso kommen da noch 2 verbindungsfehler?

dann G28 und M3001

19:09:15.247 : N67 G28*34
19:09:16.316 : N68 M105*25
19:09:19.375 : N69 M105*24
19:09:22.449 : N70 M105*16
19:09:22.465 : DigitOffset = -740
19:09:22.465 : X:0.00 Y:0.00 Z:0.00 E:0.00
19:09:25.491 : N71 M105*17
19:09:28.546 : N72 M105*18
19:09:31.608 : N73 M105*19
19:09:34.665 : N74 M105*20
19:09:36.778 : N75 M3001*35
19:09:37.719 : N76 M105*22
19:09:40.776 : N77 M105*23
19:09:43.839 : N78 M105*24

da kommen keine fehler?

gruss
siegi

trilobyte
Themenstarter
Gelegenheitsdrucker
Gelegenheitsdrucker
Beiträge: 47
Registriert: So 25. Jun 2017, 21:57
Wohnort: lenggenwil
Hat sich bedankt: 6 Mal
Danksagung erhalten: 4 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #32 von trilobyte » Di 6. Nov 2018, 19:11

AtlonXP hat geschrieben:Hallo zusammen,
wenn ich mir trilobyte veröffentlichte Matrix so anschaue, dann stellt sich mir die Frage:
Wie kann es sein, dass trilobyte unter -0,8 mm kommt mit seinem RF1000.

In unserer Community FW 1.42.xx ist doch das Limit bei -0,8 mm gesetzt?
Das dürfte doch gar nicht gehen!

@trilobyte, hast du in der RF1000.h das verändert?

LG AtlonXP


nope habe ich nicht verändert!

gruss
siegi

Benutzeravatar
Nibbels
Developer
Developer
Beiträge: 1943
Registriert: Mi 17. Aug 2016, 17:01
Hat sich bedankt: 620 Mal
Danksagung erhalten: 399 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #33 von Nibbels » Di 6. Nov 2018, 19:55

Ich patche dir was rein, dass sich 13 automatisch mit 1 überschreibt. Dauert aber etwas.

Die Verbindungsfehler sind vermutlichda, weil den drucker in dem moment neu startet.
Das Signalwort "start" ist immer das Erste, was eine Firmware sendet.

Lg
RF2000 Bausatz - Einhausung - Abluftaufsatz+Luftklappenservo - Silikonsocken - Kossel Ritzel - Sehr harte Federn - Extruder-MicroWakü - Servos - DualE3D-v6 - Carbon-Upgrade -
Firmware Mod 1.42.24.Mod

Bitte 1.42.17 bis 1.42.21 meiden!

trilobyte
Themenstarter
Gelegenheitsdrucker
Gelegenheitsdrucker
Beiträge: 47
Registriert: So 25. Jun 2017, 21:57
Wohnort: lenggenwil
Hat sich bedankt: 6 Mal
Danksagung erhalten: 4 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #34 von trilobyte » Di 6. Nov 2018, 20:38

ich kann auch codes eingebe vor dem start das wäre auch kein problem.
was mir aufgefallen ist als ich jetzt arduino nochmals gestartet habe ist die fehlermeldung das libraries nicht aktuell seien. könnte das ein problem sein?

gruss
siegi

trilobyte
Themenstarter
Gelegenheitsdrucker
Gelegenheitsdrucker
Beiträge: 47
Registriert: So 25. Jun 2017, 21:57
Wohnort: lenggenwil
Hat sich bedankt: 6 Mal
Danksagung erhalten: 4 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #35 von trilobyte » Di 6. Nov 2018, 22:01

mir ist was aufgefallen. wenn ich ein teil gedruckt habe und die Zachse ganz unten steht und dann home drücke dann kommt das hier:

21:56:14.789 : Printer reset detected - initalizing
21:56:14.789 : start
21:56:14.789 : Info:External Reset
21:56:14.789 : N1 M105*38
21:56:14.805 : Free RAM:1404
21:56:14.961 : N1 M110*34
21:56:14.961 : N2 M115*36
21:56:14.961 : N3 M105*36
21:56:14.961 : N4 M114*35
21:56:14.961 : N5 M111 S6*98
21:56:14.961 : N6 T0*60
21:56:19.740 : start Watchdog
21:56:19.771 : setupForPrinting(): invalid active heat bed z matrix detected: 13

der Drucker macht einen Reset wenn die Druckpklatte von ganz weit unten hochfährt.
Wenn ich oben stehe und home drücke passiert das nicht?

gruss
siegi

Benutzeravatar
Nibbels
Developer
Developer
Beiträge: 1943
Registriert: Mi 17. Aug 2016, 17:01
Hat sich bedankt: 620 Mal
Danksagung erhalten: 399 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #36 von Nibbels » Mi 7. Nov 2018, 00:20

Passiert das wenn du per Tastendruck im Menü unter QuickSettings das Homing startest,
oder auch wenn du per GCode G28 sendest?

(Könntest du mir die Logfile schicken, wenn du das per GCode machst? Mich interessiert die zeitliche Einordnung des Resets.)

Ausserdem könntest du mal schauen, welche Homing-Geschwindigkeit du eingestellt hast.
Das geht in den Einstellungen des Menüs unter Feedrate oder Acceleration irgendwo. Ich kann gerade nicht nachschauen. Oder im EEPROM in den Werten sieht man das auch. Die Homing-Speed sollte bei ca. 80mm/s stehen.
Steht die noch auf 100 .. 200mm/s oder ähnlich stelle das mal auf 80mm/s runter.
Bei dir greift glaube ich der Watchdog. Die Frage ist warum.

LG Stefan
RF2000 Bausatz - Einhausung - Abluftaufsatz+Luftklappenservo - Silikonsocken - Kossel Ritzel - Sehr harte Federn - Extruder-MicroWakü - Servos - DualE3D-v6 - Carbon-Upgrade -
Firmware Mod 1.42.24.Mod

Bitte 1.42.17 bis 1.42.21 meiden!

trilobyte
Themenstarter
Gelegenheitsdrucker
Gelegenheitsdrucker
Beiträge: 47
Registriert: So 25. Jun 2017, 21:57
Wohnort: lenggenwil
Hat sich bedankt: 6 Mal
Danksagung erhalten: 4 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #37 von trilobyte » Mi 7. Nov 2018, 11:22

werde das heute abend testen!

gruss
siegi

trilobyte
Themenstarter
Gelegenheitsdrucker
Gelegenheitsdrucker
Beiträge: 47
Registriert: So 25. Jun 2017, 21:57
Wohnort: lenggenwil
Hat sich bedankt: 6 Mal
Danksagung erhalten: 4 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #38 von trilobyte » Mi 7. Nov 2018, 21:45

also wenn ich den drucker anschalte und bei repetierhost auf verbinden klicke kommt das:

Code: Alles auswählen

21:17:51.885 : Printer reset detected - initalizing
21:17:51.932 : start
21:17:51.932 : Info:External Reset
21:17:51.932 : Free RAM:1404
21:17:52.135 : N1 M110*34
21:17:52.135 : N2 M115*36
21:17:52.135 : N3 M105*36
21:17:52.135 : N4 M114*35
21:17:52.135 : N5 M111 S6*98
21:17:56.831 : start Watchdog
21:17:56.862 : setupForPrinting(): invalid active heat bed z matrix detected: 13
21:18:01.466 : N6 T0*60
21:18:01.559 : N7 M20*22
21:18:01.575 : FIRMWARE_NAME:Repetier_RF.01.42.22 COMPILED:Sep 30 2018 FIRMWARE_URL:https://github.com/RF1000community/Repetier-Firmware PROTOCOL_VERSION:1.0 MACHINE_TYPE:Mendel EXTRUDER_COUNT:1 REPETIER_PROTOCOL:3
21:18:01.575 : Printed filament:228.98m Printing time:2 days 23 hours 8 min
21:18:01.575 : N8 M80*19
21:18:01.575 : N9 M105*46
21:18:01.575 : X:0.00 Y:0.00 Z:0.00 E:0.00
21:18:01.575 : N10 M220 S100*80
21:18:01.575 : N11 M221 S100*80
21:18:01.591 : Begin file list
21:18:01.591 : N12 M111 S6*84
21:18:01.591 : End file list


danach habe ich ein G28 geschickt (bett stand bereits oben in der hähe vom home) und nachher ein M3001:

Code: Alles auswählen

21:20:13.464 : N57 G28*33
21:20:16.016 : N58 M105*26
21:20:19.071 : N59 M105*27
21:20:22.134 : N60 M105*17
21:20:24.946 : DigitOffset = -821
21:20:24.946 : X:0.00 Y:0.00 Z:0.00 E:0.00
21:20:25.190 : N61 M105*16
21:20:28.244 : N62 M105*19
21:20:30.131 : N63 M3001*36
21:20:31.309 : N64 M105*21



mir ist aufgefallen dass wenn ich bei repetier host den notstopp drücke (button oben rechts mit dem blitz) dann kommt der error 13:

Code: Alles auswählen

21:22:22.144 : Printer reset detected - initalizing
21:22:22.144 : start
21:22:22.144 : Info:External Reset
21:22:22.176 : Free RAM:1404
21:22:22.253 : N1 M110*34
21:22:22.253 : N2 M115*36
21:22:22.253 : N3 M105*36
21:22:22.253 : N4 M114*35
21:22:22.275 : N5 M111 S6*98
21:22:27.101 : start Watchdog
21:22:27.133 : setupForPrinting(): invalid active heat bed z matrix detected: 13
21:22:31.743 : N6 T0*60
21:22:31.834 : N7 M20*22
21:22:31.854 : FIRMWARE_NAME:Repetier_RF.01.42.22 COMPILED:Sep 30 2018 FIRMWARE_URL:https://github.com/RF1000community/Repetier-Firmware PROTOCOL_VERSION:1.0 MACHINE_TYPE:Mendel EXTRUDER_COUNT:1 REPETIER_PROTOCOL:3
21:22:31.854 : Printed filament:228.98m Printing time:2 days 23 hours 8 min
21:22:31.854 : X:0.00 Y:0.00 Z:0.00 E:0.00
21:22:31.855 : N8 M80*19
21:22:31.855 : N9 M105*46
21:22:31.855 : N10 M220 S100*80
21:22:31.855 : Begin file list
21:22:31.855 : N11 M221 S100*80
21:22:31.855 : N12 M111 S6*84
21:22:31.855 : End file list
21:22:31.855 : N13 T0*8
21:22:34.479 : N14 M105*18



weiter habe ich versuche gemacht mit homen. wenn das Bett auf 198mm unten ist kann ich mit per tastendruck im quickmenue oder mit dem homebutton bei repetier homen und es geht. bin ich auf 199 oder auf 200mm unten und home dann die z achse (bzw home all) dann bleibt die z achse ca 5-6mm vor dem endschalter stehen und der error 13 kommt!

>Ausserdem könntest du mal schauen, welche Homing-Geschwindigkeit du eingestellt hast.
da steht bei X und Y 80 und bei Z 10. passt das?

kannst du dir einen reim auf das ganze machen?

gruss
siegi

trilobyte
Themenstarter
Gelegenheitsdrucker
Gelegenheitsdrucker
Beiträge: 47
Registriert: So 25. Jun 2017, 21:57
Wohnort: lenggenwil
Hat sich bedankt: 6 Mal
Danksagung erhalten: 4 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #39 von trilobyte » Mi 7. Nov 2018, 22:57

was bedeutet eigentlich diese fehlermeldung wenn ich den druck starte?

Code: Alles auswählen

22:46:55.000 : XY jerk was too low, setting to 17.70
22:46:55.000 : N1281 G92 E0*125
22:46:55.141 : EPR:2 75 115200 Baudrate
22:46:55.141 : EPR:2 79 0 Max. inactive time [ms,0=off]
22:46:55.141 : EPR:2 83 600000 Stop stepper after inactivity [ms,0=off]
22:46:55.141 : EPR:3 3 152.3800 X-axis steps per mm
22:46:55.141 : EPR:3 7 152.3800 Y-axis steps per mm
22:46:55.141 : EPR:3 11 2560.0000 Z-axis steps per mm
22:46:55.141 : EPR:3 15 200.000 X-axis max. feedrate [mm/s]
22:46:55.141 : EPR:3 19 200.000 Y-axis max. feedrate [mm/s]
22:46:55.141 : EPR:3 23 12.000 Z-axis max. feedrate [mm/s]
22:46:55.141 : EPR:2 1038 0 Z-Offset [um]
22:46:55.141 : EPR:0 1045 1 Z Scale
22:46:55.141 : EPR:3 129 228.981 Filament printed [m]
22:46:55.141 : EPR:2 125 256086 Printer active [s]
22:46:55.141 : EPR:3 27 80.000 X-axis homing feedrate [mm/s]
22:46:55.141 : EPR:3 31 80.000 Y-axis homing feedrate [mm/s]
22:46:55.141 : EPR:3 35 10.000 Z-axis homing feedrate [mm/s]
22:46:55.141 : EPR:3 39 13.500 Max. jerk [mm/s]
22:46:55.141 : EPR:3 47 0.300 Max. Z-jerk [mm/s]
22:46:55.141 : EPR:3 133 0.000 X home pos [mm]
22:46:55.141 : EPR:3 137 0.000 Y home pos [mm]
22:46:55.141 : EPR:3 145 245.000 X max print length [mm]
22:46:55.141 : EPR:3 149 245.000 Y max length [mm]
22:46:55.141 : EPR:3 153 200.000 Z max length [mm]
22:46:55.141 : N1282 G92 E0*126
22:46:55.141 : N1283 G1 E-1.00000 F900.00000*54
22:46:55.265 : EPR:3 51 1500.000 X-axis acceleration [mm/s^2]
22:46:55.265 : EPR:3 55 1500.000 Y-axis acceleration [mm/s^2]
22:46:55.265 : EPR:3 59 100.000 Z-axis acceleration [mm/s^2]
22:46:55.265 : EPR:3 63 1500.000 X-axis travel acceleration [mm/s^2]
22:46:55.265 : EPR:3 67 1500.000 Y-axis travel acceleration [mm/s^2]
22:46:55.265 : EPR:3 71 100.000 Z-axis travel acceleration [mm/s^2]
22:46:55.265 : EPR:3 1949 1.000 Z-Scan Start Lift [mm]
22:46:55.265 : EPR:0 1937 1 Digit Homing [1=ON/2=OFF]
22:46:55.265 : EPR:0 1938 1 Digit Compensation [1=ON/2=OFF]
22:46:55.265 : EPR:0 107 120 Bed PID I-drive max
22:46:55.265 : EPR:0 124 30 Bed PID I-drive min
22:46:55.265 : EPR:3 108 28.378 Bed PID P-gain
22:46:55.265 : EPR:3 112 0.585 Bed PID I-gain
22:46:55.265 : EPR:3 116 99.338 Bed PID D-gain
22:46:55.359 : EPR:0 120 255 Bed max power value [0-255]
22:46:55.359 : EPR:0 1922 3 Bed Temp. SensorType [0=Cfg,3=Conrad,..]
22:46:55.359 : EPR:3 200 280.000 Extr.1 steps per mm
22:46:55.359 : EPR:3 204 25.000 Extr.1 max. feedrate [mm/s]
22:46:55.359 : EPR:3 208 12.000 Extr.1 start feedrate [mm/s]
22:46:55.359 : EPR:3 212 6000.000 Extr.1 acceleration [mm/s^2]
22:46:55.359 : EPR:0 217 120 Extr.1 PID I-drive max
22:46:55.359 : EPR:0 245 30 Extr.1 PID I-drive min
22:46:55.359 : EPR:3 218 9.1810 Extr.1 PID P-gain
22:46:55.359 : EPR:3 222 2.3387 Extr.1 PID I-gain
22:46:55.390 : EPR:3 226 13.5153 Extr.1 PID D-gain
22:46:55.390 : EPR:0 230 255 Extr.1 max power value [0-255]
22:46:55.390 : EPR:0 294 3 Extr.1 Temp. SensorType [0=Cfg,3=V2,8=E3D,13=V3]
22:46:55.390 : EPR:3 231 0.000 Extr.1 X-offset [mm]
22:46:55.640 : EPR:3 235 0.000 Extr.1 Y-offset [mm]
22:46:55.640 : EPR:3 295 0.000 Extr.1 Z-offset [mm]
22:46:55.640 : EPR:1 239 20 Extr.1 temp. stabilize time [s]
22:46:55.640 : EPR:1 250 150 Extr.1 temp. for retraction when heating [C]
22:46:55.640 : EPR:1 252 0 Extr.1 distance to retract when heating [mm]
22:46:55.640 : EPR:0 254 255 Extr.1 extruder cooler speed [0-255]
22:46:55.640 : EPR:3 246 0.000 Extr.1 advance L [0=off]
22:46:55.640 : EPR:0 1000 1 beeper mode [0=off]
22:46:55.640 : EPR:0 1001 0 case lights mode [0=off, 1=on]
22:46:55.640 : EPR:0 1016 1 Z endstop type [1=single, 2=circuit]
22:46:55.640 : EPR:2 1900 25 Height of Z-Button SingleSteps [steps]
22:46:55.640 : EPR:0 1904 5 Z-Offset-Scan Position X [HBS-col]
22:46:55.640 : EPR:0 1905 5 Z-Offset-Scan Position Y [HBS-row]
22:46:55.640 : EPR:1 1906 180 SenseOffset max. Correction [um]
22:46:55.640 : EPR:1 1908 0 SenseOffset Digits Limit [1700/kg]
22:46:55.640 : EPR:2 1910 -15000 EmergencyPauseDigitsMin (min+max 0=off) [1700/kg]
22:46:55.640 : EPR:2 1914 15000 EmergencyPauseDigitsMax (min+max 0=off) [1700/kg]
22:46:55.640 : EPR:1 1918 -10000 ZEmergencyStopAllMin [1700/kg]
22:46:55.640 : EPR:1 1920 10000 ZEmergencyStopAllMax [1700/kg]
22:46:55.640 : EPR:0 1923 110 Stepper X Current [2A/126]
22:46:55.640 : EPR:0 1924 110 Stepper Y Current [2A/126]
22:46:55.640 : EPR:0 1925 105 Stepper Z Current [2A/126]
22:46:55.640 : EPR:0 1926 110 Stepper E0 Current [2A/126]
22:46:55.640 : EPR:1 1928 7000 Step Double Frequency [1/s]
22:46:55.640 : EPR:0 1930 0 Fan Modulation [0=PWM/1=PDM]
22:46:55.640 : EPR:0 1963 1 Fan PWM Divisor [15.3Hz/x]
22:46:55.640 : EPR:0 1961 1 Partfan 1% Level [1..239]
22:46:55.640 : EPR:0 1962 254 Partfan 99% Level [16..254]


XY jerk was too low, setting to 17.70
ich habe nichts verstellt... (jedenfalls nciht wissentlich)

gruss
siegi

Benutzeravatar
Nibbels
Developer
Developer
Beiträge: 1943
Registriert: Mi 17. Aug 2016, 17:01
Hat sich bedankt: 620 Mal
Danksagung erhalten: 399 Mal

Re: Probleme mit dem Heat Bed Scan

Beitrag #40 von Nibbels » Do 8. Nov 2018, 00:01

Guten Abend :)

Viel Stoff...
1) Ich fange aber mal mit meinem Thema an.
Diese ext. EEPROM Schreibegeschichte habe ich aufgeräumt und heute noch eine Autokorrektur mit eingebaut.
Änderungen: https://github.com/Nibbels/Repetier-Fir ... 831677adb6
Dazu kommt, dass ich vor die kritischen Funktionen, wo 0 übergeben hätte werden können eine Abfrage eingebaut habe. Dieser uAddress-0-Fehler darf nun überhaupt nicht mehr auftreten, ausser es läuft mit der Firmware oder deinem Prozessor was grundlegend falsch.

Lade dir bitte mal diese 1.43.06 von meinem persönlichen Github-Account runter.
(Die heißt nun .43 statt .42, weil ich die Entwicklungsumgebung geändert habe, sodass ich zukünftig mehr Überblick habe.)

-> https://github.com/Nibbels/Repetier-Firmware

Ich habe getestet, was ich konnte, der Codestand sollte funktionieren.

Diese Zeile:

Code: Alles auswählen

21:17:56.862 : setupForPrinting(): invalid active heat bed z matrix detected: 13

Muss mit der neuen Firmware eigentlich wegfallen.

2) Ich sehe deine Homing-Feedrate für X und Y ist auf 80, was ok sein sollte.
Du kannst versuchen, die Homing-Feedrate für Z von 10 auf z.B. 8 oder 7 verändern. Der Hintergrund ist, dass eine minderschnelle Bewegung in Z wegen der hohen Steprate [32Microsteps in Kombination mit der Spindelsteigung] den kleinen Rechner sehr fordert. Evtl. ist dein Watchdog etwas Triggerhappy und löst etwas früher aus als andere. Bleibt nicht genug Rechenpower für Hintergrundarbeit wie Watchdogresets könnte es zu so einem Problem kommen.
Darum der Tipp mal auf 8 oder 7mm/s beim Z-Homing zu testen.

(Was ich ganz "spannend" finde ist, dass die Firmware irgendwas zersemmelt, wenn sie sehr angestrengt rechnet. So einen Fehler hatten wir schonmal und damals wars ein Overflow in einem der Interrupts bei zu hoher Last. Ich glaube aber eigentlich nicht mehr dran und will darum möglichst viel anderes ausschließen. Ausserdem wüsste ich aktuell nicht, wo da noch was schieflaufen sollte.)

3)

Code: Alles auswählen

XY jerk was too low, setting to 17.70
Das passiert, wenn man die Acceleration hochstellt. Prüfe mal bitte deinen GCode, den du da ausgeführt hast, ob nicht M201 oder M202 drin vorkommt und deine Beschleunigung auf einen höheren Wert setzt, als diese 1500.
Siehe wiki/index.php/GCodes#M201_-_Setze_max._Beschleunigungswerte_in_Einheiten.2Fs.C2.B2_f.C3.BCr_Druckbewegungen
Ich würde dieses Umstellen der Beschleunigung generell aus Startcodes verbannen!
Das gehört da nicht rein und 1500 ist ein sehr guter Wert für unsere Drucker.
Meiner Meinung nach 1000 Minimum 2000 Maximum, 1500 ist schon ziemlich ideal.

Warum wird der Jerk erhöht? Weil wegen der Numerik beim Berechnen der Startgeschwindigkeiten und Beschleunigungen hier ein Minimal-Jerk vorgegeben wird. Je kleiner die Beschleunigungen sind, desto kleiner kann der Jerk sein.
(Da ein Jerk von etwa 10..15 bei unseren Druckern ideal scheint, passt der Beschleunigungsbereich von 1000 bis 2000 ganz gut dazu.)

4) Ich bin nun gespannt, ob der 13er Fehler verschwindet ;)
Wenn nein, dann packe mir bitte die gesamte Firmware genau so wie du sie kompiliert hast und schicke sie mir zu!
Wenn möglich sichere wenn du die Firmware aufspielst die folgende Datei für mich:
C:\Users\%USERNAME%\AppData\Local\Temp\arduino_build_123456\Repetier.ino.elf
Die ist nur leider weg, sobald man Arduino wieder schließt.

LG
RF2000 Bausatz - Einhausung - Abluftaufsatz+Luftklappenservo - Silikonsocken - Kossel Ritzel - Sehr harte Federn - Extruder-MicroWakü - Servos - DualE3D-v6 - Carbon-Upgrade -
Firmware Mod 1.42.24.Mod

Bitte 1.42.17 bis 1.42.21 meiden!


Zurück zu „Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast